Cisco QoS on DSL

By steve, 5 November, 2013

I have been looking after QoS settings on a site using a Cisco router for a number of years, and had issues with it not doing what I expected. The design was to use a hierarchy to guarantee bandwidth to certain classes of traffic, but allow all traffic to use the full bandwidth if other classes did not need theirs. I discovered that you need to apply the service-policy to the ATM PVC (for a DSL WIC) in order for it to work as expected, and NOT to the dialer interface. The config I used is below:

class-map match-any high-priority
match access-group name high-priority
class-map match-any match-icmp
match protocol icmp
class-map match-any low-priority
match access-group name low-priority

policy-map dsl-policy
class high-priority
priority percent 80
class low-priority
priority percent 5
class match-icmp
priority percent 3
class class-default
priority percent 10

policy-map dsl-qos
class class-default
shape average percent 80
queue-limit 500 ms
service-policy dsl-policy

interface ATM0/1/0
no ip address
no atm ilmi-keepalive
pvc 8/35
vbr-nrt 1000 1000 1
service-policy out dsl-qos
pppoe-client dial-pool-number 2
!
end

ip access-list extended high-priority
permit/deny

ip access-list extended low-priority
permit/deny

The vbr-nrt setting is required on the PVC in order to set the bandwidth.
At the top level we have a 80% QoS setting with a maximum of 500ms queueing.
On the next level we assign a priority to each class to guarantee bandwidth.

Tags

Comments